Linux APT 无法处理包依赖的关系

问题原因:Ubuntu安装软件时经常会因为软件包之间的依赖关系无法完成安装。

解决方案: sudo apt install aptitude:完成aptitude命令

安装 sudo aptitude install 软件包 :自动安装某个软件包

遇见这个选项,选n

 Keep the following packages at their current version: 1) libssl-dev [Not Installed] 2) node-gyp [Not Installed] 3) nodejs-dev [Not Installed] 4) npm [Not Installed] Accept this solution? [Y/n/q/?] ?

注:aptitude这个命令可以自动处理安装包之间的依赖关系